Маленькая заметка о новой фичи. Конечно ещё рано говорить полноценном функционале, но ребята из MikroTik нас радуют, и новый функционал просто бомба. IEEE 802.1BR

!!!Естественно так как пока это тестирование, не о каком проде речи быть не может.

Встречайте Bridge Controller

Без всяких слов, посмотрим как использовать сие чудо =)

Берём одну из железок из списка CRS309-1G-8S,CRS317-1G-16S,CRS312-4C+8XG,CRS326-24S+2Q,CRS354-48G-4S+2Q,CRS354-48P-4S+2Q+. (список не окончательный и скорее всего будет расширяться). Устанавливаем последнюю testing версию RouterOS.

И на железке выполняем следующее:

Создаём bridge

/interface bridge
add name=bridge-local vlan-filtering=yes

Запускаем контроллер указанием, что у нас есть два порта к которому подключены другие устройства MikroTik.

/interface bridge port-controller
set bridge=bridge-local cascade-ports=sfp-sfpplus1,sfp-sfpplus2 switch=switch1

Далее берём в моём случае два устройства, из списка netPower 15FR (CRS318-1Fi-15Fr-2S),netPower 16P (CRS318-16P-2S+),CRS326-24G-2S+ (RM/IN),CRS328-24P-4S+,CRS328-4C-20S-4S+,CRS305-1G-4S+,CRS309-1G-8S+,CRS317-1G-16S+,CRS312-4C+8XG,CRS326-24S+2Q+,CRS354-48G-4S+2Q+,CRS354-48P-4S+2Q+(список не окончательный и скорее всего будет расширяться).

Подключаем наши устройства именно в порты нашего контроллера, которые указали в параметре cascade-ports!!!

Оба коммутатора подключены своим sfp-sfpplus1 портом. Далее на каждом коммутаторе выполняем команду.

/interface bridge port-extender
set control-ports=sfp-sfpplus1 switch=switch1

Тем самым указываем в каком порту находится контроллер. bridge создавать не нужно, всё будет сделано автоматически.

Если необходимо подключить устройства каскадом, то на проходных коммутаторах, необходимо указать дополнительный port-extender до следующего коммутатора.

Вы всегда можете посмотреть подключенные устройства на контроллере командой /interface bridge port-controller device print

[admin@mikrotik-ctrl] >/interface bridge port-controller device print
Flags: I - inactive
 0   name="pe1" pe-mac=64:D1:54:bb:AA:01 descr="MikroTik RouterOS 6.48beta35 (testing) CRS328-24P-4S+" control-ports=pe1-sfpplus1,pe1-sfpplus2

 1   name="pe2" pe-mac=64:D1:54:bb:BB:02 descr="MikroTik RouterOS 6.48beta35 (testing) CRS326-24G-2S+" control-ports=pe2-sfpplus1
[admin@Controller] > /interface bridge port-controller device monitor pe2
                 name: pe2
               status: active
  connected-via-ports: sfp-sfpplus1==pe1-sfpplus1,pe1-sfpplus2==pe2-sfpplus1
   connected-via-devs: controller,pe1

Теперь на контроллере вам доступны все интерфейсы всех подключенных коммутаторов и вы можете их настраивать как вам вздумается.

Особенность данного стандарта IEEE 802.1BR в том, что каждый фрейм инкапсулируется специальной меткой и отправляется на контролер и контролер решает куда необходимо отправить данный фрейм согласно своим внутренним FDB и ACL и отправляет этот фрейм, опять же с меткой на необходимый коммутатор. Таким образом весь трафик проходит через контроллер.

Рассказать друзьям

Чатик телеграм

@mikrotikme